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About this guide The PhoneSoft™ Unified Messaging Trial SoftwareInstallation Guide contains 
instructions for installing and setting upUnified Messaging Trial Software. The 
latest version of this guide can be found at:  http://www.activevoice.com/prod-
ucts/phonesoft/. 

The guide focuses on Unified Messaging Trial Software. For extensive infor-
mation about the installation, setup and use of third-party software and hard-
ware, refer to the manufacturer’s documentation.

For information on using Unified Messaging Trial Software, please refer to the 
User Guide.

Documentation conventions
The guide uses the following conventions: 

User Input   Information that the user types appears in Courier: tedit 

Key names  Key names appear in capital letters: ENTER. 

Cascading selections  The “>” symbol separates the selections you make: on 
menus (Programs > Dialogic System Software > Configuration Manager); in 
the navigation levels of Unified Messaging Trial Software; and in menu trees. 
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Installation 
overview

The following steps offer general guidelines for setting up  a new version of 
Unified Messaging Trial Software. 

Setup steps
1 Confirm the minimum system requirements.

See “Minimum system requirements” on page 8. 

2 Collect all installation checklist components. 
See “Installation checklist” on page 8.

3 Install voice boards.
See “Installing voice boards” on page 10.

4 Set up the phone system integration.
See “Setting up the phone system” on page 15.

5 Install Unified Messaging Trial Software.
See “Installing and starting Unified Messaging Trial Software” on 
page 19.

6 Set up Unified Messaging Trial Software.
See “Changing default settings” on page 21, “Setting up users” on 
page 25 and “Setting up phone lines” on page 32. 

7 Install optional Unified Messaging Trial Software packages.
See “Installing RealSpeak” on page 33, “Installing additional languages” 
on page 34 and “Setting up Play By Phone and Play Multimedia” on 
page 36.

8 Customize automated attendant. 
See the PhoneSoft Software Development Kit User Guide for details. 

9 Using Soft Phone with the trial software
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Upgrading from E-Mail Reader to Unified Messaging Trial 
Software

To upgrade from E-Mail Reader to the latest version of Unified Messaging 
Trial Software, use the Windows NT or Windows 2000 Uninstall program to 
uninstall E-Mail Reader and then follow the Setup steps above to install 
Unified Messaging Trial Software. 

E-Mail Reader and Unified Messaging Trial Software have a few shared set-
tings that may already be set up for E-Mail Reader. When you find fields or 
procedure steps that are already set up or done, you can skip them and go to the 
next installation step.
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Installation 
requirements and 
checklist

Minimum system requirements
■ Pentium III 600 MHz (or higher) computer with a CD-ROM drive and 

monitor.

■ Windows 95, 98, ME, NT 4.0 with Service Pack 3 (or higher) or Win-
dows 2000 Server.

■ 128MB of RAM.

■ 100 MB of available hard disk space.

■ Lotus Notes client or Domino server version 4.6 or higher software, 
which is installed and set up on the computer. 

■ The computer’s system path contains the Notes or Domino directory. To 
confirm and set up the path, see “To confirm the system path exists” on 
page 9.

■ An available ISA or PCI computer slot.

■ At least one ISA or PCI voice board that corresponds with the available 
slot.

■ Unified Messaging Trial Software can be installed on either a Notes cli-
ent computer or a Domino server. For systems with: 

■ Less than 16 ports, you can run Unified Messaging Trial Software 
on the same computer as the Domino server that stores the applica-
ble databases. 

■ 16 or more ports, run Unified Messaging Trial Software on a sepa-
rate dedicated Notes client computer that is connected to the appli-
cable Domino server.

NOTES: Additional memory may increase performance. If you are running 
other applications on the same computer, 128 MB of RAM may be needed.

Installation checklist
■ Computer that meets the minimum system requirements.

■ Unified Messaging Trial Software software and documentation.

■ License diskette, which contains the license file that you receive from 
your sales representative. This file is not available on the Internet. 

■ Password that is in the Readme file on the license diskette.
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To confirm the system path exists

1 At a DOS prompt on the Unified Messaging Trial Software computer, 
type notes and press ENTER.

2 If Notes or Domino start, the path exists. If Notes or Domino does not 
start, perform one of the following three procedures, as appropriate.

To set up the computer’s system path for Windows NT

1 From the Start menu on the Unified Messaging Trial Software computer, 
select Settings>Control Panel and then double-click “System.”

2 In the System Properties dialog box, select the Environment tab. 

3 In the System Variables list, locate and select “Path.”

4 In the value field, select and go to the end of the value and type a semico-
lon (;) and the Notes or Domino directory path. For example: 

%systemroot%system32%systemroot%;C:\Notes

5 Save the changes and close the dialog box. 

6 For the changes to take affect, shut down and restart the computer.

7 Confirm the path is set correctly by repeating steps 1 through 3 above.

To set up the computer’s system path for Windows 2000

1 From the Start menu on the Unified Messaging Trial Software computer, 
select Settings>Control Panel and then double-click “System.”

2 Click “Advanced” and then click “Environment variables.” 

3 In the System Variables box, locate and select the path and then click 
“Edit.”

4 At the end of the current path, type a semicolon (;) and the Notes or Dom-
ino directory path. For example: 

%systemroot%system32%systemroot%;C:\Notes

5 Click “OK” and close the dialog box. 

6 Confirm the path is set correctly by repeating the “To confirm the system 
path exists” procedure above.
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Installing voice 
boards

Unified Messaging Trial Software requires a voice board, which is a phone 
interface card, to physically connect phone lines or extensions from the phone 
system (or the phone company’s system) to the Unified Messaging Trial Soft-
ware system. 

Before installing Unified Messaging Trial Software, install and set up the voice 
boards. All Dialogic voice boards are shipped with installation and setup 
instructions.

The following Dialogic voice boards are supported by PhoneSoft Unified Mes-
saging Trial Software.

To find and reserve memory addresses and an IRQ address (for ISA 
boards only)

1 On the Dialogic System Software disc, run the Dialogic Configuration 
Manager utility to reserve resources for a legacy ISA board, including:
■ 32 KB of memory in the D0000 range (D0000 to DFFFF).
■ IRQ 5.
If IRQ 5 is already in use by a PCI board (a network interface card, for 
example), you can force the system to reserve IRQ 5, which will cause 
the PCI board to use another IRQ. If IRQ 5 is not available, try IRQ 7 or 
2.

2 Write down the memory addresses that you reserved. You will need to 
specify these values when setting up the voice board.

Continued

Board Bus
ProLine/2V ISA
Dialogic D/41EPCI PCI
Dialogic D/41ESC ISA
Dialogic D/41H ISA
Dialogic D/120JCT-LS PCI
Dialogic D/160SC-LS ISA
Dialogic D/240PCI-T1 PCI
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Installing a voice board

1 Attach an antistatic wrist strap.

2 If you already turned on the computer, shut down the software and then 
shut down the computer. 

3 Remove the cover from the computer or expansion chassis. 

4 Select an empty ISA or PCI slot as appropriate, and remove the slot's 
retaining screw and access cover plate.

NOTES: PCI boards can be put into either 32-bit or 64-bit PCI slots.

All ISA boards and all boards with SC or CT bus connectors must be 
installed in the same box. If not all boards fit in the Unified Messaging 
Trial Software computer, then you must install all of them in an expansion 
chassis.

5 Perform the applicable procedures to set the switches and jumpers on 
each board. See “Appendix” on page 21.
Some boards include hardware settings that indicate which board is first, 
which is second, and so on. If you are installing more than one board of 
the same model, keep the boards in order so you can install them in the 
correct order in the next step.

6 Insert each board firmly into its slot, and fasten each board to the com-
puter’s backplate with a screw.
If you are installing more than one board of the same model, and if the 
boards include a hardware setting that indicates which board is first, sec-
ond, and so on, install the boards in the order specified by the hardware 
settings.

7 If you are installing multiple voice boards that have SC or CT bus con-
nectors, cable the boards together. On each board, connect the cable so 
the red stripe on the cable corresponds with pin 1 on the board connector. 
Confirm that the connectors are firmly seated.
If the cable has more connectors than the computer has voice boards, use 
the first and last connectors, and leave unused connectors in the middle of 
the cable. If the end of a cable is allowed to dangle loose, it can act as a 
radio antenna and pick up noise from the bus.
If you are cabling three or more boards together, connect the first connec-
tor on the cable to the first board, the second connector to the second 
board, and so on.

8 Replace the cover of the computer or expansion chassis.
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Setting up the 
voice boards

After installing one of the supported Dialogic voice boards, install the driver 
software. 

If you purchased the voice boards from Active Voice, your voice board pack-
age includes a Dialogic System Software disc. 

The following procedures are provided as examples of a typical installation and 
setup. The Dialogic installation program provided for your voice boards may 
be slightly different. For detailed instructions, refer to the voice boards’ docu-
mentation. 

To set up the voice boards, perform the following procedures. 

To test that a board was installed and set up correctly, perform “To test a 
board’s setup” on page 14. 

To install the Dialogic software

1 Insert the Dialogic System Software disc in the Unified Messaging Trial 
Software computer’s CD-ROM drive.

2 Go to the disc’s directory and double-click the Setup.exe file.

3 Follow the on-screen instructions and select the Typical Installation 
option. 

To set up the boards

1 From the Windows Start menu, select Programs> Dialogic System Soft-
ware>Configuration Manager. 

2 Click the Add Board to Configuration menu. 

3 Click the board that you are installing. 

4 Follow the on-screen instructions to set up the board. 

5 After completing the setup, repeat steps 1 through 4 for each board. 

6 After setting up all of the boards, click “End Configuration,” save your 
settings and exit the utility.

Continued
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To set up the board to automatically start with the computer

1 From the Start menu, choose Programs>Dialogic System Software. 

2 Click “Service” and then click “Start Up Mode.”

3 Click “Automatic.”

4 For Windows NT systems, perform the next procedure.
For Windows 2000 systems, perform “To install the WAV driver files for 
Windows 2000” on page 14.

To install the WAV driver files for Windows NT

1 From the Start menu, choose Settings>Control Panel. 

2 Double-click “Multimedia.”

3 In the Properties box, choose the Devices tab and then click “Add.”

4 Click “Unlisted or updated driver” and then click “OK.”

5 In the Install Driver dialog box, click “Browse.”

6  Go to the directory that contains the Dialogic drivers and choose the Lib 
subdirectory. The default directory is C:\Program files\Dialogic\Lib. 

7 Click “OK” twice.

8 When the “Add uninstalled or updated driver” dialog box appears, con-
firm that “Dialogic WAV Driver 1.x” is displayed and then click “OK.”

9 If a message appears indicating that the file already exists, click “New.”

10 From the Dialogic Wave Driver Configuration box, choose “OK” to 
accept the default settings.

11 Restart the computer to update the system.
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To install the WAV driver files for Windows 2000

1 From the Start menu, choose Settings> Control Panel. 

2 Double-click “Add/Remove Hardware.”

3 From the Add/Remove Hardware Wizard dialog box, click “Next.”

4 Select “Add/Troubleshoot a device” and then click “Next.” 

5 Select “Add a new device,” then click “Next.”

6 Select “No, I want to select the hardware from a list” and click “Next.”

7 Select “Sound, video and game controllers” and click “Next.” 

8 When asked to select a device driver, select “Standard system devices” 
and then click “Have Disk.”

9 Go to the directory that contains the Dialogic software and then go to the 
Lib subdirectory. 

10 Open the Oemsetup.inf file and click “OK.”

11 Confirm that “Dialogic Wave Driver 1.x” is selected and then click 
“Next.”

12 Select “Hardware Installation” and click “Next.”

13 When the Digital Signature dialog box appears, click “Yes.”

14 If the Files Needed dialog box appears, confirm that the path is set cor-
rectly and click “OK.”

15 At the Dialogic Wave Driver Configuration dialog box, click “OK” and 
then click “Finish.”

16 Restart the computer to update the system.

To test a board’s setup

1 From the Windows Start menu, select Programs> Dialogic System Soft-
ware>Universal Dialogic Diagnostic Utility. 

2 Click the board that you want to test. 

3 Click “Run Tests.” It may take several minutes for these to run. 
If any errors are reported, resolve them before continuing with the Uni-
fied Messaging Trial Software installation process. 
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Setting up the 
phone system

How the integration works
Phone lines connect the phone system and the Unified Messaging Trial Soft-
ware computer. Unified Messaging Trial Software supports many types of ana-
log, DID (Direct Inward Dial), and digital (T1, E1) phone lines. The voice 
board installed in the Unified Messaging Trial Software computer must match 
the lines from the phone system or the phone company’s central office. 

The following illustration shows a typical Unified Messaging Trial Software 
and phone system integration.

With a typical integration, the phone system may send the following informa-
tion with forwarded calls:

■ The called party’s extension

■ The reason for the forward (the extension is busy, does not answer, or is 
set to forward all calls)

■ The calling party’s extension (for internal calls)

PHONE
SYSTEM

Mobile
phone

Phone

Fax

UNIFIED MESSAGING
COMPUTER NOTES/DOMINO

INTERNET
SUBSCRIBERS
• E-mail client

SUBSCRIBER
• E-mail client

• Unified Messaging
• Lotus Notes or
• Domino
• DECtalk or
• RealSpeak
• Windows NT/2000

INTERNET

NETWORK
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Unified Messaging Trial Software uses this information to answer the call 
appropriately. For example, a call forwarded to Unified Messaging Trial Soft-
ware is answered with the user’s personal greeting. If the phone system routes 
the call to Unified Messaging Trial Software without this information, Unified 
Messaging Trial Software answers with the opening greeting.

Unified Messaging Trial Software offers one or more of the following that may 
take advantage of features found on your phone system. 

Call forward to personal greeting  When an incoming call is routed to an unan-
swered or busy extension, the call is forwarded to the user’s voice mail. The 
caller then hears the user’s personal greeting and can leave a message. To set 
up this feature, you need to use the PhoneSoft SDK Script Generator and a 
Lotus agent.

Easy message access  If the phone system uses a serial integration (SMDI or 
MCI), a user can retrieve messages without entering an ID. Unified Messaging 
Trial Software identifies a user based on the extension from which the call 
originated. A password may be required. To set up this feature, you need to use 
the PhoneSoft SDK Script Generator and a Lotus agent. 

Message waiting indication (MWI)  When a message is waiting for a user, Uni-
fied Messaging Trial Software notifies the phone system to activate the mes-
sage waiting indicator on the user’s extension.

Setting up the phone system
The following procedure provides general information about setting up a phone 
system; refer to your phone system documentation for specific information.

To set up the phone system

1 Assign extensions for the voice mail ports, which are the lines connecting 
the phone system and Unified Messaging Trial Software.

2 If the phone system supports hunt groups, set up the hunting order for the 
voice mail extensions (port 1 to port 2, and so on).
If the phone system does not support hunt groups, you can simulate a 
hunt group by forwarding each voice mail extension to the next extension 
in the simulated hunt group on busy.

Continued

3 If the phone system supports hunt group access codes, assign a hunt group 
access code for the voice mail extensions. This code is the number that 
users dial internally to connect to Unified Messaging Trial Software.

4 Program which trunks (if any) will route to the voice mail extensions.
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5 Program the phone system to handle calls when all voice mail ports are 
busy. Calls may be forwarded to an operator, get a busy signal, or get a 
ringback tone until one of the ports becomes available.

Testing the setup
To test that the phone system is set up correctly, perform the following proce-
dure. 

To test the phone system setup

1 Locate a standard analog phone set with a ringer. If the system uses fea-
ture phone sets, use a feature set for the test.

2 If the voice boards use RJ-14 connectors, locate a line splitter to separate 
the two extensions carried by each phone line.

3 Connect the test phone set to the phone system by using a line designated 
as a voice mail extension.

4 Confirm that the phone system identifies DTMF (dual tone multiple fre-
quency) tones to the test extension.
Do this by dialing a station phone from the test phone. Have someone 
answer the station phone and dial a number. You should hear the tone on 
the test phone. Repeat this test for each type of station connected to the 
phone system (for example, analog or operator).

5 Confirm that the test phone can access outside lines. 
To do this, dial a number outside of the phone system from the test phone. 
You should reach the outside number. 

6 Confirm that the phone system generates rings on the test extension. 
To do this, use a station phone to dial the test phone’s extension. The test 
phone should ring. 

7 For phone systems that support trunk routing, check that trunk routing is 
set up correctly for extensions that only answer calls from stations. 
To do this, dial the test phone’s extension from a station phone. Answer 
the test phone and perform a hookflash (timed break recall); then dial a 
station phone, listen for ringing, and disconnect. The call should be trans-
ferred to the phone that you dialed. 



SETTING UP THE PHONE SYSTEM18

Connecting Unified Messaging Trial Software and the 
phone system
After setting up and testing each of the voice mail phone lines on the phone 
system, you need to connect the two systems. 

The type of phone line that you use to connect the two systems, depends on the 
type of voice boards installed in the Unified Messaging Trial Software com-
puter. Refer to “Appendix” on page 21 for information about a supported voice 
board’s connectors and port size.

To connect the phone system to Unified Messaging Trial Software

❚ Connect a phone line from each phone system extension to a socket on 
the voice board backplate of the Unified Messaging Trial Software com-
puter.
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Installing and 
starting Unified 
Messaging Trial 
Software

Installing Unified Messaging Trial Software
After setting up the voice boards and the phone system integration, perform the 
following to install Unified Messaging Trial Software. 

After installation, you can set up Unified Messaging Trial Software to automat-
ically start when the computer starts. To do this, set up Unified Messaging Trial 
Software as an NT Service by performing the second procedure. 

To install Unified Messaging Trial Software

1 Locate and open the Unified Messaging Trial Software Setup_umc.exe  
installation file.

2 Click “Yes” when asked if you want to install the software.

3 When asked, type the password that you received with the license file and 
then click “OK.”

NOTE: The password is case sensitive.

4 Follow the on-screen instructions to complete the installation.

5 Copy the Umailcall.lic file into the directory that contains the 
Phoneserver.exe file.
If you received the Umailcall.zip file in an e-mail message, copy the file 
to a temporary directory, unzip it and then copy the Umailcall.lic file to 
the same directory as the Phoneserver.exe file.

To set up Unified Messaging Trial Software as an NT Service

1 From the Start menu, choose the Run menu.

2 Type phoneserver_-i and click “OK.”

3 Start Phone Server. 

4 In the Phone Line Status Grid box, double-click each phone line and click 
“Autostart.”
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Starting Unified Messaging Trial Software’s Phone Server
Phone Server provides a system administrator interface for setting up and 
maintaining Unified Messaging Trial Software and the phone system integra-
tion.

You can use Phone Server to monitor system status and examine system utili-
zation.

To start Phone Server

❚ From the Start menu, choose the Programs>PhoneSoft>Phone Server 
menus.

To close Phone Server

❚ Click the File>Exit menus.
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Changing default 
settings

Before Unified Messaging Trial Software can answer calls, you need to set up 
the system. 

The standard installation sets up the system with the common defaults for auto-
mated attendant and other system options. To modify the standard setup, per-
form the procedures below.

To change phone line settings

1 Start Phone Server.

2 Go to the Phone Line Status Grid and double-click the phone line for 
which you want to change the settings.

To change Unified Messaging Trial Software default settings

1 From the Phone Server menu bar, select the Edit>Configuration menus. 

2 In the Phone Server Properties dialog box, you can change the settings 
available in these windows. Refer to the Phone Server Help File for set-
ting descriptions. 

Automated attendant options
After the corporation’s opening greeting, callers are offered a menu of options. 
The system administrator can redefine these options. By default, the following 
options are provided: 

Extension number   The system will transfer a call when a caller enters a user’s 
extension at any time during the greeting. 

0 (Operator)  Callers can dial 0 to call the operator during most menu conver-
sations. Any extension or phone number can be set up as the operator.

NOTE: Callers with rotary phones or callers who do not dial a menu selection 
are also transferred to the operator. 

1 (Spell-by-name directory assistance)  This option transfers calls to the direc-
tory for spelling a user’s name. Directory assistance can be set up to present 
names beginning with either first or last name. Up to ten letters may be entered. 
The order of the name is determined by the NAB database “Name” field. 

Call transfer
Depending on the phone system, call transfers can be set up in a variety of dif-
ferent ways. The phone system transfer settings are set up in the Phone Server 
Edit>Configuration>Transfer Settings menu. 
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By default, when a call is answered by a user, the call is released. When a call 
is unanswered or busy, these are the default menu choices a caller hears:

1 Leave a voice message    

2 Transfer to another extension  

3 Page the user  Available for a user that is set up with an enabled pager.

4 Hold until the extension is available  The system waits for a set time, and 
then tries the extension again.

0 for the operator  

Modifying menu and prompt settings
All system menu choices and prompt settings can be modified. You can mini-
mize user training by customizing menus and prompts to match up with what 
users are used to using. 

The custom prompts directory can contain custom or site specific prompts for 
your application. When a prompt is stored in this directory it takes precedence 
over the file of the same name in the Prompts directory. Files in this directory 
are not removed during a PhoneSoft reinstall, upgrade or uninstall.

To modify a Unified Messaging menu

1 In Phone Server, click the Edit>Mailcall>Menus menus. 

2 Make changes as appropriate.

3 After modifying a menu setting, click “Apply” and then click “OK.” 

To modify a prompt

1 After recording your custom prompts, rename the files to match the files 
that you are replacing. 

2 Then copy the customized prompt into the C:\PhoneSoft\MailCall\Cus-
tomPrompts directory. 

Message waiting indication
Depending on how the phone system is set up, Unified Messaging Trial Soft-
ware can send signals to turn the user’s MWI (message waiting indicator) on or 
off, as appropriate. 
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Unified Messaging Trial Software has two options for setting up message wait-
ing indication. You can set up the system to set MWI on when a new message 
appears in: 

■ Any of the user’s mailbox folders or views. 
■ The user’s inbox folder. This option is faster and more appropriate for 

sites with 500 or more users. 

Unified Messaging Trial Software supports SMDI (simple message desk inter-
face) signaling. SMDI signaling is a serial connection between the phone sys-
tem and Unified Messaging Trial Software. If the phone system supports an 
SMDI link, please contact your sales representative for more information. The 
Unified Messaging Trial Software SMDI interface is sold separately.

To set up SMDI signaling

1 Locate and copy the Smdi.lic file to the directory that contains the 
Phoneserver.exe file. The default is C:\PhoneSoft.

2 Start Phone Server. 

3 Click the Edit>SMDI Link menus. 

4 In the SMDI Link dialog box, select the “SMDI Link Enabled” check 
box. 

5 Select the appropriate “Com port,” and “PBX type,” and then click “OK.”

6 When the message appears, click “OK.”

7 In Phone Server, click the Edit>Configuration menus and select the MWI 
Settings tab. 

8 Select the Enable MWI check box and type the appropriate time In the 
“Update Period” field. 

9 Then click “Use SMDI Link.” 

10 In the Unread Handling section, click “Match Inbox (Single Folder)” and 
click “OK.”

11 Close and restart Phone Server.

DID environments
If the corporation uses DID (Direct Inward Dial) extensions, callers can auto-
matically forward busy or unanswered calls directly to the user's mailbox.
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Changing message sort order
Unified Messaging Trial Software supports customizing a Notes view for sort-
ing and viewing messages in various ways. The system is limited to one con-
figured view for each user. 

Call Pursuit
Unified Messaging Trial Software can intelligently attempt to find a user and 
transfer a call to a forwarding number. Users can set up their mailboxes with 
multiple forwarding numbers, and the system will sequentially try each of 
these numbers. You can make this option available (or unavailable) to users 
through Notes.  

For Call Pursuit of external phone numbers, the phone system must be set up 
for three-way conference calls with external phone numbers. 
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Setting up users Unified Messaging Trial Software stores user settings in a Domino directory or 
Notes NAB (Name and Address Book). 

Unified Messaging Trial Software can use either your company's existing NAB 
or a separate NAB. System administration is simpler when using the company 
NAB. For example, when adding user names and settings, the users will auto-
matically be set up to use Unified Messaging Trial Software as well. 

A sample database is included with Unified Messaging Trial Software. This 
NAB contains the additional forms, views, and fields required by Unified Mes-
saging Trial Software. 

To set up users in the company NAB, copy these views and fields into that 
NAB by performing the procedure below. To set up users in the sample NAB, 
perform the procedure that starts on page 27. 

After performing one of the following two procedures, you need to set up users 
to access their mail files over the phone. See “To set up Unified Messaging 
Trial Software to access a company’s NAB” on page 30. For further assistance, 
contact your company’s Notes or Domino administrator. 

To set up users in the company NAB

1 On the Unified Messaging Trial Software computer, log in to Notes or 
Domino. 

2 If using the company NAB, continue to step 3. 
If using a replica of the company NAB, locate and create a replica of the 
company’s NAB (default is Names.nsf), from the Domino server to the 
Unified Messaging Trial Software client, into the \Lotus\Notes\Data 
directory. 

3 Click the Domino Designer icon. 

4 Locate and open the Unified Messaging Trial Software PS Names mail 
database (Psnames.nsf) in the \Phonesoft directory. 

5 Locate and open the company NAB on the server or the replica NAB in 
the \Lotus\Notes\Data directory.

6 In the PS Names mail database, click “Forms” and then open the Person 
form for editing.

7 Highlight and copy all of the PhoneSoft fields.

8 Go to the company’s NAB or replica NAB, click “Forms,” and then open 
the Person form for editing.
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9 If using Notes or Domino version 4.6 or earlier, do the following:

■ Locate the Misc section, click once below the Misc section to get 
the cursor in that area and then click the Edit>Paste menus. 

■ Confirm that all of the PhoneSoft fields appear in the Person form 
list between the Misc and Public Keys sections. 

If using version 5.0 or higher, click on a Person tab that you want to add 
the PhoneSoft tab after and do the following: 

■ Right-click and click the Insert Row menu. 

■ Select the new tab, right-click and click the Table Properties Menu. 
In the Table Row tab, type PhoneSoft in the “Tab Label” box and 
close the Table dialog box. 

■ Select the PhoneSoft tab, right-click and click the Paste menu to 
copy in the PhoneSoft fields. 

10 Close and save the updated Person form. 

11 In the PS Names mail database, click “Views” and then open the Person 
view for editing.

12 Highlight and copy all of the PhoneSoft fields.

13 Go to the company’s NAB or replica NAB, click “Views,” and then open 
the Person view for editing.

14 If using Notes or Domino version 4.6 or earlier, do the following:

■ Locate the Misc section, click once below the Misc section to get 
the cursor in that area and then click the Edit>Paste menus. 

■ Confirm that all of the PhoneSoft fields appear in the Person form 
list between the Misc and Public Keys sections. 

If using version 5.0 or later, click on a view tab that you want to add the 
PhoneSoft tab after and do the following: 

■ Right-click and click the Insert Row menu. 

■ Select the new tab, right-click and click the Table Properties Menu. 
In the Table Row tab, type PhoneSoft in the “Tab Label” box and 
close the Table dialog box. 

■ Select the PhoneSoft tab, right-click and click the Paste menu to 
copy in the PhoneSoft fields.

Continued

15 If using the company’s NAB, skip to step 19. 
If using a replica NAB, click the File>Database>Properties menus. 
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16 Confirm that the window has the Replica NAB title and then click the 
Design tab. 

17 To save the field additions to the Replica NAB only, clear the “Inherit 
design from template” check box. 

18 Save and close the Database Properties window. 

NOTE: If you want everyone using the template database to have these 
buttons, repeat this procedure for the template database. 

19 Close and save the updated Person view and exit Domino Designer. 

20 For each user, type the appropriate information for each PhoneSoft field. 
For field descriptions, see step 4 in the next procedure below.

To set up users in the sample NAB

1 Locate and copy the Psnames.nsf file from C:\PhoneSoft to the 
Lotus\Notes\Data directory on the Unified Messaging Trial Software 
computer.

2 Start Domino Designer and open the Psnames.nsf file, which is the sam-
ple NAB. 

3 Click the Create>Person menus to add each user into the sample NAB. 

4 The information required for each user allowed to call in or receive mail 
from Unified Messaging Trial Software is contained in the Person Docu-
ments in the NAB. Set up the following fields for each user. 

Canonical name  Stores the user’s full Notes canonical name and uses it 
for unread messages. For example, CN=Sandy Green/O=Active Voice. 

Spelled last name  Stores the user’s last name. Automatically computes 
the keypad number of last names. For example, Green is saved as 47336. 

Mail address  Stores the user's Notes mail address. 

Mail server  Stores the mail server’s name containing the user's mail file. 
Unified Messaging Trial Software supports user mail files residing on 
different mail servers.

Mail file  Stores the user’s mail file name and directory path. This name 
and path must match the user’s corresponding mail file name and path in 
the mail server's database. For example, Mail\sgreen.nsf. 

Mailbox number  Stores user’s mailbox number, extension, employee 
number or any other number that is unique to this user. A user enters this 
number to access his or her mailbox.
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Mailbox password   Stores the user’s password. You can set this for the 
user and then have the user change it later. This field is protected using 
Notes one-way encryption.

Name recording  Stores the user's name recording as a Wav file. 

Greeting  Stores the user's greeting as a Wav file. For example, I’m 
unavailable to take your call. Please leave me a message.” 

Absence greeting  Stores the greeting played when this greeting is 
enabled and the user is unavailable to answer the call. For example, “I’m 
out of the office, but will check messages in the morning.” When this 
greeting is active, the “Log missed calls” field is ignored and no call 
screening message recordings are sent for these missed calls. 

NOTE: The “Do not disturb” setting that is available with some phone 
systems, is not recognized by Phone Server. However, the user can use the 
Absence greeting as a “Do not disturb” setting for Phone Server.

Phone extension  Three fields for storing three user phone system exten-
sions or external phone numbers that Unified Messaging Trial Software 
can use to contact the user. The first field value is usually the same as the 
“Mailbox Number” field. 
When more than one “Phone extension” field is used, Unified Messaging 
Trial Software calls each extension, one at a time, to contact the user, 
which is also known as Call Pursuit. 
You can use the three field settings to resolve situations when different 
extensions are required. For example, when a user wants to receive calls 
on a cellular phone, the user can set up one of these fields to forward all 
calls to the cellular phone number. 

Enable or disable extension  Enables or disables the use of the corre-
sponding “Phone extension” field. 
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Type  Sets the type of call transfer to the corresponding “Phone exten-
sion” field. Settings include default, blind or supervised.  The most com-
mon settings are supervised for external numbers and default for internal 
extensions. 
With the default setting, the system uses whatever the phone system is set 
up to do. However, Unified Messaging Trial Software can override the 
phone setting with either the blind or supervised setting. 
With a blind transfer, the extension is dialed and then the call is released 
immediately.  Because the call is released, the other two phone extensions 
are not used. 
With a supervised transfer, the call is monitored by the system and is 
released if the call is answered. If the called extension is busy or unan-
swered, then the system tries any other set phone extensions and then 
handles the call based on what is set up for that user. For further details, 
see “How the integration works” on page 15 and “Call transfer” on 
page 21. 

Pager address  Stores the user’s e-mail address for the user’s pager. See 
the Notes Pager Gateway Administrator's Guide for details.

Numeric page string  The dial string needed to send the numeric page.

Enable or disable pager  Enables or disables the use of the “Pager 
address” field.

Call screening enabled  Enables or disables call screening for a user’s 
extension.

Confirm deletions  Set for users that want a confirmation message before 
deleting a message from their mailbox.

Log missed calls  Set for users that have Call screening enabled and want 
to receive just the call screening recording from a caller that leaves no 
message or if the call transfer failed. 
When a user’s Absence greeting is active, this field is ignored and no call 
screening message recordings are sent for these missed calls. 

Conversation monitoring  Enables the use of conversation recording or 
monitoring.

Machine name  Store's the user’s computer name for the Popup feature. 
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MWI state  Used by the system to display MWI status; cannot be 
changed. 

View selection  Sets the view used for reviewing messages by phone.

5 Confirm that all of the PhoneSoft fields appear in the Person form list 
between the Misc and Public Keys sections. 

6 Close and save this form. 

To set up Unified Messaging Trial Software to access a company’s NAB

1 Start Phone Server and click the Edit>Configuration menus. 

2 In the Phone Server Properties dialog box, click the “Names server” field. 

3 Do one of the following:
■ If using a company’s NAB on the Domino server, type the NAB file 

name. Local files must be stored in the \Lotus\Notes\Data directory. 
■ If the NAB database is located on the Unified Messaging Trial Soft-

ware computer, leave this field blank. 

4 Click “OK” to save the settings.

To create a Phoneserver Notes ID for the Unified Messaging Trial 
Software computer

1 Open Domino Administrator and go to the People section of the com-
pany’s mail database.

2 Click the People section and then click the Tools list. 

3 From the Tools list, click the People list and then click “Register.”

4 In the New Entry dialog box, click the Registration Server button. 

5 From the Registration Server list, locate and select the Domino domain 
name of the company’s mail database and click “OK.”

6 In the “Last Name” field, type phoneserver. 

7 In the “Password” field, type a password. 

8 Select the “Advanced” check box and then click the ID Info icon. 

9 Select the “In File” checkbox and then click “Set ID File.”

Continued

10 In the “File name” box, type a name, click “Save” and close the dialog 
box.

11 Click “Add person” and then click “Register” to create the ID. 
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NOTE: Notes security is best maintained by using a separate ID, 
because only the system administrator has access to this special Notes 
ID, and no user has any access to any other user's mail file. 

To add the Phoneserver ID to the Access Control List for each user mail 
file

1 Open a user’s mail file in Notes or Domino. 

2 Click the File>Database>Access Control menus.

3 In the Access Control List dialog box, click “Add.” 

4 Click the Person icon and then browse the Domino server to locate the 
Phoneserver person ID (that you just created in the previous procedure). 

5 Select the Phoneserver person, click “Add” and then click “OK.”

6 In the Access Control List dialog box, select the Phoneserver person and 
then from the Access list, click “Manager.”  Manager access is required 
for accurate unread message information. 

7 To allow a user to delete mailbox messages over the phone, select the 
“Delete documents” check box in the Access Control List dialog box.

8 Repeat this procedure for each user mail file. 
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Setting up phone 
lines

You may want to change the system default settings for the phone lines. To 
change the settings, perform the following procedure. 

After changing the settings for a phone line, you can test the setup by calling in 
to the phone number or extension shown for that line.

To set up a phone line

1 In the Telephone Line Status Grid, double-click the line that you want to 
set up.

NOTE: If the fields are grayed out, then an application may be active on 
that line. To stop activity, click “Stop” and then click “Yes.” 

2 In the Line Setup dialog box, go to the “Phone #” field and type the exten-
sion number that the phone system will use to access this line.

3 In the Application list, select “Unified MailCall” and click “Start” to start 
the application. 

4 If you want Phone Server to automatically run the selected application on 
this line, select the “Auto Start” check box. 

5 Click “Close” to complete the setup. 

6 Repeat this procedure for each phone line.

NOTE: When a phone line is set up correctly, the Status Grid displays 
the application as up and running and the Activity displays “Waiting for 
Call.” 
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Installing 
RealSpeak

RealSpeak™ is an optional TTS package that provides a more natural sounding 
voice. 

US English is the TTS language included and installed with RealSpeak. 

To install this package, perform the procedure below. 

To install RealSpeak

1 Confirm that the system is using version 5.1A or higher of PhoneSoft 
software. If not, contact your sales representative to upgrade. 

2 Locate and double-click the Realspeak_tts_us_v2b.exe file on the Phone-
Soft disc. 

3 When asked, type your password and click “OK.” The password is 
located in the Readme file on your license diskette.

4 When asked, type the Unified Messaging Trial Software directory path 
that contains the Umailcall.exe file. The default is C:\PhoneSoft\Mailcall.

5 Follow the on-screen instructions to complete the installation.

6 After clicking “Finish,” start Phone Server. 

7 Click the Edit>Configuration menu and then click the TTS tab. 

8 In the Interface box, click “RealSpeak.” 

9 In the Key box, type the license key code and click “Upgrade.” The code 
is located in the Readme file on your license diskette. 

10 Confirm the appropriate number of TTS licenses are displayed above the 
Key box. If the wrong number appears, confirm that you typed the code 
correctly. 

11 Close the Configuration box and restart Phone Server. 
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Installing 
additional 
languages

When using DECtalk™ Text To Speech (TTS), Unified Messaging Trial Soft-
ware automatically installs the US English language for you. When using Real-
Speak, you need to install the language when you install RealSpeak. 

In order to use other available languages or additional languages withUnified 
Messaging Trial Software, you will need to install them after installing Unified 
Messaging Trial Software. 

The following are examples of other available languages that are included on 
the PhoneSoft disc for DECTalk.

■ German (Dectalk_gr_tts.exe)

■ Latin American Spanish (Dectalk_la_tts.exe)

■ Castilian Spanish (Dectalk_sp_tts.exe)

■ United Kingdom / British English (Dectalk_uk_tts.exe)

At the time this was published, English was the only language available with 
RealSpeak. 

After receiving one or more language files, perform the following two proce-
dures to install and set up TTS languages.

After setting up the system for multiple languages, as described on page 35, 
callers can press 2 to change to a different TTS language. The menu options 
will be presented in the order listed in the Mailcall.ini file. The "Language_x" 
lines define the language to be selected by pressing the corresponding menu 
numbers. The "Description_x" lines define the corresponding menu option 
played for each menu number.

To install a TTS language

1 Locate the language file on the PhoneSoft disc. 

2 Copy the language file to a temporary directory on the Unified Messaging 
Trial Software computer.

3 Locate and write down the language’s password that is listed in the 
Readme file on the license diskette.

4 Double-click the language file.

5 When asked, type the appropriate password as found in step 3.

6 When asked, type the Unified Messaging Trial Software directory path 
that contains the Umailcall.exe file. The default is C:\PhoneSoft\Mailcall.

7 Repeat this procedure for each language that you want to install.

Continued
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To set up Unified Messaging Trial Software for multiple TTS languages

1 Use a text editor to open the Mailcall.ini file. 

2 Locate the TTS Languages section in the file. 

3 Specify the default and the order in which the other languages are offered. 
For example, type the following for US English as the default and the 
other language options in the order listed.

[TTS Languages]

Language_1=ENGLISH, US

Description_1=American English

Language_2=ENGLISH, UK

Description_2=The Queen's English

Language_3=SPANISH

Description_3=Spanish

Language_4=LATIN AMERICAN

Description_4=Latin American Spanish

Language_5=GERMAN

Description_5=Deutsch

4 Save and close the file. 
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Setting up Play 
By Phone and 
Play Multimedia

PS Desktop is an optional TTS (text to speech) client application for Phone-
Soft. With PS Desktop, users can click either the Play By Phone or Play Multi-
media button and listen to inbox messages over their phones. 

Perform the following three procedures to install and set up PS Desktop and the 
buttons in the Notes or Domino NAB database. The PS Desktop buttons will 
then be available from that NAB database’s Memo Form. 

Use the second procedure to install the PS Desktop buttons in any Notes inbox 
folder, view or form. PS Desktop uses a Unified Messaging Trial Software port 
while a message is playing. 

NOTE: If using a replica database and you want everyone using the Notes 
template database to also use the PS Desktop buttons, repeat the last two pro-
cedures for the template database. 

To install PS Desktop

1 Confirm that TCP/IP is set up on the client and the Unified Messaging 
Trial Software computers.

2 Confirm that the IP network is installed correctly. You can use Chatter 
and Chatsvr, which are two Microsoft programs included with PS Desk-
top.

3 Locate and double-click the Ps_desktop.exe file.

4 In the Attachment Properties dialog box, click “Launch.” The 
self-extracting file installs the software.

5 From the Start menu, click Programs>Phonesoft>PS_Desktop to start the 
utility.

6 Select Edit>Phone Number and type the user’s phone extension.

7 Select Edit >Phone Server Name and type the IP address of the computer 
running the voice mail system (or if your IP addresses are dynamic, type 
the Windows Network Name).

8 Close the program. 

Continued
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To add “Play by phone” and “Play multimedia” to a user’s memo form

1 Start Domino Designer by clicking the Start>Programs>Lotus Applica-
tion>Lotus Domino Designer menus. 

2  From Domino Designer, click the File>Database>Open menus and type 
the directory path and name to open the Psmail.nsf file. 

3 Do the same to open the NAB database for which you want to add the PS 
Desktop buttons.

4 Under Recent databases, locate “PS Sample Mail Database R5.”

5 To open the Psmail.nsf memo form, click “Forms” and then double-click 
“Memo.”    

6 Confirm the Action Pane window is visible in the Domino Designer win-
dow. If not, click View/Action and select the “Action pane” check box. 

7 In the Psmail.nsf memo form, click the “Play multimedia” action once 
and then click the Edit>Copy menus. 

8 Under Recent databases, locate the Notes NAB database for which you 
want to add the PS Desktop buttons. 

9 To open the NAB database memo form, click “Forms” and then dou-
ble-click “Memo.”

10 If the NAB database is a template, skip to step 14. 
If the NAB database is not a template, a message appears about losing 
any changes made to the form because the master copy is in a different 
design template database. Go to the next step.

11 Click the File>Database>Properties menus and click the Design tab. 

12 To save the additions of these buttons to this database only, clear the 
“Inherit design from template” check box. 

13 Save and close the Properties window. 

14 From the Domino Designer, confirm the Action Pane window is visible in 
the NAB database. 

15 Paste the “Play multimedia” action from the Psmail.nsf file to the NAB 
database. 
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16 In the Action Pane window, click the first action and then click the 
Edit>Paste menus to copy “Play multimedia.”

17 In the Action Pane window of the Psmail.nsf file, select the “Play by 
phone” action and then click the Edit>Copy menus. 

18 In the Action Pane window of the NAB database, click the first action and 
then click the Edit>Paste menus to copy “Play by phone.”

19 Save and close the NAB database memo form. 

20 Repeat this procedure for all users that you want to use “Play by phone” 
and “Play multimedia.” 

To add the Play By Phone and Play Multimedia agents to the NAB 
database

1 From Domino Designer, click the File>Database>Open menus and type 
the directory path and name to open the Psmail.nsf file. 

2 Do the same to open the NAB database for which you want to add the 
macros.

3 Under Recent databases, locate “PS Sample Mail Database R5.”

4 To open the Psmail.nsf agents, click “Agents” and then click “PS Multi-
media Playback.”

5 Press and hold CRTL and click “PS telephone playback.”

6 Click the Edit>Copy menus to copy both agents. 

7 Under Recent databases, locate the Notes NAB database for which you 
want to add the PS Desktop agents. 

8 To open the NAB database agents, click “Agents” and then click any-
where in the Agents Pane window to make it the active window. 

9 Click the Edit>Paste menus to paste the agents. 

10 Confirm the agents are listed and then close and save the NAB database 
Agents Pane window. 
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Troubleshooting 
read and unread 
messages

Lotus Notes read and unread message problems can be caused by copies of the 
unread message lists not matching up or conflicting.  

A copy of the unread message list for each user is stored by Lotus Notes in 
three places: 
■ Notes mailbox database 
■ User's Desktop.dsk file
■ Notes client as an unread journal log in the Cache.dsk file

When PhoneSoft queries a mailbox database for unread messages, Notes 
returns the list of unread documents from the database.  PhoneSoft then 
arranges and presents the unread messages to the user.  The number of unread 
messages when calling from the phone should be the same as the number of 
unread messages viewed in the mailbox from the Notes client or browser on 
any computer. 

Canonical name problem
Lotus Notes uses the User's Canonical Name to track unread messages.  The 
“Canonical Name” field is located in the PhoneSoft section of the Domino 
NAB.

If this field is incorrectly set up in the NAB, the user receives a different num-
ber of unread messages from the phone, as compared to the Notes desktop. 

To find the “Canonical Name” field value

1 Open the users mail file. 

2 Find a document created by that user, highlight and right-click the docu-
ment. 

3 Select the Document Properties menu. 

4 Click the Fields tab. 

5 In the “From” field list, locate the correct Canonical Name as shown on 
the bottom right of the window (example: CN=Sandy Green/O=Your 
Company). 

6 Highlight, copy, and paste this Canonical Name into the Unified Messag-
ing Trial Software NAB “Canonical name” field. (Do not copy the 
quotes.)
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Mail file open conflict
When user mail files are open on their desktops and  they check  messages over 
the phone, the read and unread message information can be inaccurate.  The 
inaccuracy is caused by Notes updating the database copy of the unread list 
only when user mail files are closed on the desktop.  This situation is resolved 
by Notes when users close their mail files. 

Access Control List problem
Notes requires that the Notes ID for the Unified Messaging Trial Software 
computer have the Manager access level to user mail files. Without Manager 
access, users are unable to receive read and unread message information and a 
corresponding error appears in the Phone Server log when users try to check 
unread messages. See “To create a Phoneserver Notes ID for the Unified Mes-
saging Trial Software computer” on page 30. 

View problems
By default, Unified Messaging Trial Software searches for and reads messages 
from the Notes ($Inbox) folder.  To create a custom view, you can create a 
view named $PS Review. When the $PSReview view exists in user mailboxes, 
Unified Messaging Trial Software automatically uses that view instead of the 
$Inbox view for reviewing all phone based messages. 

For Unified Messaging Trial Software to successfully use the $PS Review 
view, specific column positions are mandatory.  See the sample database, the 
Psmail.nsf file, for column positions.  

When Unified Messaging Trial Software uses a specific view ($Inbox or $PS 
Review) for message review, only unread messages in that view are seen by 
Unified Messaging Trial Software.

Replica database problems
When using replica database files with Unified Messaging Trial Software and 
Notes, users can get confused by inaccurate read and unread message informa-
tion. Unread message information does replicates between database replicas, 
however it is not always immediate. So when users check unread messages 
both by phone and desktop close to the same time, the message counts can be 
inaccurate, because replication has not yet occurred. 

Continued
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Notes servers earlier than version 4.5
With this older software, an error message appears in the Phone Server log that 
an unsupported function was attempted when users try to check unread mes-
sages with Unified Messaging Trial Software.

Notes server software that is earlier than version 4.5 lacks support for access-
ing unread message information from a Notes server.  Earlier versions only 
support API access to unread message information in local databases. 

To resolve this lack of support, leave the “Notes Server” field blank, and type 
in a network mapped path (such as Z:\Notes\Data\Mail) to each  user's mail file 
as if the file were local. 

Notes limitations
Lotus has solutions for unread message problems documented in the Lotus 
Notes Knowledge Base. For details, see:

■ Document 169936, “Are unread marks fixed in release 5?”

■ Document 160731, “How do unread marks work in a Notes/Domino 4.x 
environment?”

■ Document 179683, “Two common unread mark scenarios: new mail 
appears read and already opened mail appears unread”
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Minimizing problems
You can minimize or often eliminate the problems described in this section. Do 
one or more of the following to resolve the most common problems: 
■ Confirm that users always access the same mail file replica as Unified Mes-
saging Trial Software. If users access different replicas, unread message infor-
mation may be inaccurate. 
■ If one of the replicas is a local replica (on a client), use the 
"Replicator_sync_unread=-1" setting in the Notes.ini file on that client.  Doing 
so forces unread synchronization during each replication and minimizes errors. 
■ Access all replicas frequently.  If users wait long periods of time between 
accessing a given replica, older unread entries in the Notes journal file may be 
overwritten and lost before replayed to other replicas. 
■  Avoid using the "Mark all read" or "Mark all unread" settings when using 
very large mail files (over 1,000 documents) with multiple replicas, because 
the Notes journal file does not track these unread changes to other replicas. 
■ When using multiple replicas, use the Notes R5 Workspace page to unstack 
replica icons. Select two of the replicas and force replication of the unread 
tables by clicking the Edit>Unread Marks>Exchange Unread Marks menus.  
This sets up a manual process, but is more powerful than the 
"Replicator_sync_unread=-1" setting, because it allows unread replication 
between multiple server based replicas. 
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Proline 2V 
voice board

����������

ON

Switch block SW1
Jumper JP7 and IRQ5

Side view

Top view SW1

Voice board backplate

Connection pinouts
The Proline 2V uses 
RJ-14 connectors.

Line 1

Line 2Pin 1: Unused

Pin 2: First port tip

Pin 3: First port ring

Pin 4: Unused

MIC

IN

JP5 and JP6

OUT
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Hardware settings
Do the following procedures as you install voice boards.

To set switch block SW1 and jumpers JP5, JP6, and JP7

The switch block SW1 and jumper JP6 settings identify the voice board’s 
memory address, which in turn specifies which voice messaging ports are on 
which board. The jumper JP7 setting specifies which board is in the first slot.

1 Set SW1 switches on each board as shown below.

2 Set jumpers JP5, JP6, and JP7 as shown below.

To set jumper JP1 (IRQ setting)

❚ Set jumper JP1 on all boards to position 4, IRQ 5, as shown in the dia-
gram at left.

SW1 JP5 JP6 JP7
Memory 
address

First board
Ports 1–4

D0000

Second board
Ports 5–8

D2000

Third board
Ports 9–12

D4000

Fourth board
Ports 13–16

D6000

On
Of1 2 3 4

On
Of1 2 3 4

On
Of1 2 3 4

On
Of1 2 3 4
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Dialogic D/41H  
ISA voice board

����������

ON

Switch block SW1

Jumper JP7 and IRQ5

Side view

Top view

SW1

Voice board backplate

Connection pinouts
The D/41H uses 
RJ-11 connectors.

Line 1

Line 2Pin 1: Unused

Pin 2: First port tip

Pin 3: First port ring

Pin 4: Unused

Line 3

Line 4
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Hardware settings
Do the following procedures as you install voice boards.

To set switch block SW1 and jumpers JP5, JP6, and JP7

The switch block SW1 and jumper JP6 settings identify the voice board’s 
memory address, which in turn specifies which voice messaging ports are on 
which board. The jumper JP7 setting specifies which board is in the first slot.

1 Set SW1 switches on each board as shown below.

2 Set jumpers JP5, JP6, and JP7 as shown below.

To set jumper JP1 (IRQ setting)

❚ Set jumper JP1 on all boards to position 4, IRQ 5, as shown in the dia-
gram at left.

SW1 JP5 JP6 JP7
Memory 
address

First board
Ports 1–4

D0000

Second board
Ports 5–8

D2000

Third board
Ports 9–12

D4000

Fourth board
Ports 13–16

D6000

On
Of1 2 3 4

On
Of1 2 3 4

On
Of1 2 3 4

On
Of1 2 3 4
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Dialogic 
D/41E PCI voice 
board

Jumpers JP2– Jumpers JP6–
JP7Switch

SW1
Switch 
SW2

Voice board backplate

Line 1

Line 2

Connection pinouts
The D/41E PCI uses 
RJ-11 connectors.

Line 3

Line 4

Side view

Pin 4: Unused
Pin 3: Ring

Pin 2: Tip

Pin 1: Unused



QUICK START INSTALLATION GUIDE 27

Hardware settings
Do the following procedures as you install voice boards.

To set the SW1 switch

❚ For each Dialogic PCI voice board that has a rotary switch, set the rotary 
switch to a unique value starting with 1 and continuing in sequence.

For example, set the rotary switch on the first three PCI voice boards in 
the Reception server as shown below. This is also the order in which you 
install the boards in the server. 

To set switch block SW2

❚ Set SW2 switches to “Off” on all boards.

To set jumpers JP2 to JP7

❚ Set jumpers JP2 to JP5 to “Off” on each board. For jumpers JP6 and JP7, 
install shunts on the top two pins (1 and 2). 

First PCI board

Second PCI board

Third PCI board

JP2 JP3 JP4 JP5 JP6 JP7
Setting

1

2

3
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Dialogic 
D/41ESC 
voice board

Pin 1: Unused

Pin 2: First port tip

Pin 3: First port ring

0

����

SC bus connector Switch SW1 Switch block SW2

Top view

Side view

Connection pinouts
The D/41ESC uses 
RJ-11 connectors.

Voice board backplate

Line 1

Line 2

Line 3

Line 4
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Hardware settings
Do the following procedures as you install voice boards.

To set the SW1 switch

❚ For each Dialogic ISA voice board that has a rotary switch, set the rotary 
switch to a unique value starting with 0 and continuing in sequence. 

For example, set the rotary switch on the first three ISA voice boards in 
the Reception server as shown below. This is also the order in which you 
install the boards in the server. 

To set switch block SW2

❚ Set SW2 switches to “Off” on all boards.

First ISA board

Second ISA board

Third ISA board

0

1

2
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Dialogic 
D/120JCT-LS 
voice board

Voice board backplateConnection pinouts
The D/120JCT-LS uses RJ-25 
connectors.

Lines 1 and 2

Lines 3 and 4

Lines 5 and 6

Lines 7 and 8

Pin 6: Earth recall 2
Pin 5: Ring 2

Pin 4: Tip 1
Pin 3: Ring 1

Pin 2: Tip 2
Pin 1: Earth recall 1

Switch SW100Switch SW1

Side view

Top view

Lines 9 and 10

Lines 11 and 12

CT bus connector
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Dialogic D/120JCT-LS 

Continued
voice board

Hardware settings
Do the following procedures as you install voice boards.

To set the SW100 switch

■ For each Dialogic PCI voice board that has a rotary switch, set the rotary 
switch to a unique value starting with 1 and continuing in sequence. 

For example, set the rotary switch on the first three PCI voice boards in 
the Reception server as shown below. This is also the order in which you 
install the boards in the server. 

To set the SW1 switch

❚ Set switch SW1 to “On hook” on all boards as shown below.

First PCI board

Second PCI board

Third PCI board

1

2

3

On hook
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Dialogic 
D/160SC-LS 
voice board

SC bus
connector

Switch
SW100

Switch 
SW600

DB-37 connector

Top view

Side view

Connection pinouts
The D/160SC-LS uses a DB-37 
connector. See the table on the next 
page for pinout information.

Pin 1 Pin 20
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DB-37 pinouts

u Pin 37 is the ground.

u Pins 17, 34, 35, and 36 are unused.

Continued

Line number Tip connection Ring connection

1 Pin 1 Pin 18
2 Pin 2 Pin 19
3 Pin 3 Pin 20
4 Pin 4 Pin 21
5 Pin 5 Pin 22
6 Pin 6 Pin 23
7 Pin 7 Pin 24
8 Pin 8 Pin 25
9 Pin 9 Pin 26
10 Pin 10 Pin 27
11 Pin 11 Pin 28
12 Pin 12 Pin 29
13 Pin 13 Pin 30
14 Pin 14 Pin 31
15 Pin 15 Pin 32
16 Pin 16 Pin 33
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Dialogic D/160SC-LS 

Continued
voice board

Hardware settings
Do the following procedures as you install voice boards.

To set the SW100 switch

❚ For each Dialogic ISA voice board that has a rotary switch, set the rotary 
switch to a unique value starting with 0 and continuing in sequence. 

For example, set the rotary switch on the first three ISA voice boards in 
the Reception server as shown below. This is also the order in which you 
install the boards in the server. 

To set the SW4 switch

❚ Set switch SW4 to “Off hook” on all boards as shown below.

First ISA board

Second ISA board

Third ISA board

0

1

2

Off hook
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Dialogic 
D/240PCI-T1 
voice board

Switch SW100

Top view

Side view

Voice board 
backplate

LED status
indicators

T1 trunk
interface

O
N

1

Pin 1: Receive ring
Pin 2: Receive tip
Pin 3: Chassis ground
Pin 4: Transmit ring
Pin 5: Transmit tip
Pin 6: Chassis ground
Pin 7: Chassis ground
Pin 8: Chassis ground

Connection pinouts
The D/240PCI-T1 uses an 
RJ-48C connector.

JP2–JP7CT bus connector
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Hardware settings
Do the following procedures as you install voice boards.

To set the SW100 switch

❚ For each Dialogic PCI voice board that has a rotary switch, set the switch 
to a unique value starting with 1 and continuing in sequence. For exam-
ple, set the switch on the first three PCI voice boards in the Reception 
server as shown below. Install the boards in the server in the same order. 

To set jumpers JP2 to JP7

❚ Set jumpers JP2 to JP5 to “Off” on each board. For jumpers JP6 and JP7, 
install shunts on the top two pins (1 and 2). 

LED status indicators
The D/240PCI-T1 includes the following status indicators.

First PCI board

Second PCI board

Third PCI board

JP2 JP3 JP4 JP5 JP6 JP7
Setting

Color Lit

Green The board is powered up and receiving an external signal
Yellow Loss of frame synchronization at far end of external network
Red Loss of frame synchronization on incoming line from external network

1

2

3
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 telephone system. See  phone system

A
Absence greeting field 26
Access Control List

setup ID with Manager access 28
troubleshooting 38

accessing NAB 28
automated attendant options 20
automatic startup 12

B
blind transfer 27

C
call forwarding. See call transfer
Call Pursuit 23, 26
Call screening field 27
call transfer

blind 27
default settings 20– 21
integration options 15
setup for phone extension 27
supervised 27

Canonical name field
setup 25
troubleshooting 37

card. See voice boards
changing Unified Messaging settings 20
checklist for installation 7
computer requirements 7
Confirm deletions field 27
connecting Unified Messaging and the phone system 17
Conversation monitoring field 27

D
D/120JCT-LS voice board 50

D/160SC-LS voice board 52
D/240PCI-T1 voice board 55
D/41E PCI voice board 46
D/41ESC voice board 48
D/41H ISA voice board 44
DECtalk

installation 32
languages setup 33

default settings for Unified Messaging 20
Dialogic System Software disc

installing software 11
IRQ setup 9
voice board setup 11

Dialogic voice boards 9, 41
Dialogic WAV drivers, installing 12
DID (direct inward dial) options 22
directory assistance settings 20
Domino

directory path setup 8
ID setup 28
Manager access setup 28

E
easy message access, integration overview 15
errors. See  troubleshooting
extension setup 26

F
field descriptions for PhoneSoft Person form 25
forwarding calls. See call transfer

G
Greeting field 26

H
hardware requirements 7
hunt groups, setup 15
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I — K
ID setup for Notes or Domino 28
installing

checklist for 7
DECtalk 32
Dialogic software 11
Dialogic WAV drivers 12
languages for TTS 32
overview 6
Play By Phone and Play Multimedia 34
RealSpeak 31
system requirements for 7
Unified Messaging 18
upgrade software 6
voice board settings 41
voice boards 9

integration, phone system overview 14
IRQ setup 9
ISA voice boards 9, 41

L
languages

installing DECtalk 32
multiple language setup 33

Log missed calls field 27

M
Machine name field 27
Mail address field 25
Mail file field 26
Mail Server field 25
Mailbox number field 26
Mailbox password field 26
Manager access, setting for Notes 28
menu and prompt settings 21
message sort, changing 23
message waiting indication (MWI)

integration overview 15
options 21

multiple extension setup 26
multiple extensions setup 23
multiple language setup 33
MWI state field 27

N
NAB (Name and Address Book) setup 24– 28
Name recording field 26
Notes

directory path setup 8
ID setup 28
Manager access setup 28
troubleshooting 39

NT service setup 18
Numeric page string field 27

O
opening Unified Messaging 19
operator settings 20
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P — Q
Pager address field 27
path, system path setup 8
PCI voice boards 9, 41
Person form PhoneSoft field descriptions 25
Phone # field 30
Phone extension fields 26– 27
phone lines setup 30
Phone Server, starting 19
phone system

connecting to Unified Messaging 17
hunt group setup 15
setup 15
setup overview 14
testing setup 16

PhoneSoft form field descriptions 25
Play By Phone setup 34
Play Multimedia setup 34
problem solving

minimizing errors 40
unread message information 37

Proline 2V voice board 42
prompt and menu setttings 21
PS Desktop setup 34
PSF Names (sample database) setup 25

R
RealSpeak installation 31
recording conversations, Conversation monitoring field 27
replica NAB database

setup 24
troubleshooting 38, 40

S
sample database setup 25
setting up

Access Control List for Unified Messaging 28
access to NAB 28
field descriptions for PhoneSoft 25

hunt groups 15
languages 33
mail database or NAB 24
menus and prompts 21
multiple languages 33
Notes ID 28
phone lines 30
phone system integration 15
Play By Phone 34
Play Multimedia 34
replica NAB database 24
Unified Messaging as NT service 18
users 24– 28
voice boards 11

signaling, SMDI setup 22
SMDI support and setup 22
software requirements 7
software update 6
sort order, changing for messages 23
Spelled last name field 25
starting Phone Server 19
startup, automatic 12
supervised transfer 27
system path, setup and confirm 8
system requirements 7

T
testing

phone system setup 16
voice board setup 13

transferring calls. See call transfer
troubleshooting

Access Control List 38
mail file open conflict 38
minimize problems 40
Notes software 39
read and unread messages 37
replica NAB database 38
view problems 38

TTS (text to speech)
installing languages for DECtalk 32
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installing RealSpeak 31
multiple language setup 33

U
Unified Messaging

changing settings 20
connecting to phone system 17
installing 18
SMDI support 22
starting 19

unread message information, troubleshooting 37
updating software 6
upgrading from E-Mail Reader 6

V
View selection field 27
voice boards

D/120JCT-LS 50
D/160SC-LS 52
D/240PCI-T1 55
D/41E PCI 46
D/41ESC 48
D/41H ISA 44
illustrations 41
installing 9
Proline 2V 42
settings 41
setup 11
supported list 9
testing setup 13

W — Z
WAV driver installation 12
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	To set up users in the company NAB
	1 On the Unified Messaging Trial Software computer, log in to Notes or Domino.
	2 If using the company NAB, continue to step 3.
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	7 To allow a user to delete mailbox messages over the phone, select the “Delete documents” check ...
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	Setting up phone lines
	To set up a phone line
	1 In the Telephone Line Status Grid, double-click the line that you want to set up.
	2 In the Line Setup dialog box, go to the “Phone #” field and type the extension number that the ...
	3 In the Application list, select “Unified MailCall” and click “Start” to start the application.
	4 If you want Phone Server to automatically run the selected application on this line, select the...
	5 Click “Close” to complete the setup.
	6 Repeat this procedure for each phone line.


	Installing RealSpeak
	To install RealSpeak
	1 Confirm that the system is using version 5.1A or higher of PhoneSoft software. If not, contact ...
	2 Locate and double-click the Realspeak_tts_us_v2b.exe file on the PhoneSoft disc.
	3 When asked, type your password and click “OK.” The password is located in the Readme file on yo...
	4 When asked, type the Unified Messaging Trial Software directory path that contains the Umailcal...
	5 Follow the on-screen instructions to complete the installation.
	6 After clicking “Finish,” start Phone Server.
	7 Click the Edit>Configuration menu and then click the TTS tab.
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	9 In the Key box, type the license key code and click “Upgrade.” The code is located in the Readm...
	10 Confirm the appropriate number of TTS licenses are displayed above the Key box. If the wrong n...
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	Installing additional languages
	To install a TTS language
	1 Locate the language file on the PhoneSoft disc.
	2 Copy the language file to a temporary directory on the Unified Messaging Trial Software computer.
	3 Locate and write down the language’s password that is listed in the Readme file on the license ...
	4 Double-click the language file.
	5 When asked, type the appropriate password as found in step 3.
	6 When asked, type the Unified Messaging Trial Software directory path that contains the Umailcal...
	7 Repeat this procedure for each language that you want to install.

	To set up Unified Messaging Trial Software for multiple TTS languages
	1 Use a text editor to open the Mailcall.ini file.
	2 Locate the TTS Languages section in the file.
	3 Specify the default and the order in which the other languages are offered. For example, type t...
	4 Save and close the file.


	Setting up Play By Phone and Play Multimedia
	To install PS Desktop
	1 Confirm that TCP/IP is set up on the client and the Unified Messaging Trial Software computers.
	2 Confirm that the IP network is installed correctly. You can use Chatter and Chatsvr, which are ...
	3 Locate and double-click the Ps_desktop.exe file.
	4 In the Attachment Properties dialog box, click “Launch.” The self-extracting file installs the ...
	5 From the Start menu, click Programs>Phonesoft>PS_Desktop to start the utility.
	6 Select Edit>Phone Number and type the user’s phone extension.
	7 Select Edit >Phone Server Name and type the IP address of the computer running the voice mail s...
	8 Close the program.

	To add “Play by phone” and “Play multimedia” to a user’s memo form
	1 Start Domino Designer by clicking the Start>Programs>Lotus Application>Lotus Domino Designer me...
	2 From Domino Designer, click the File>Database>Open menus and type the directory path and name t...
	3 Do the same to open the NAB database for which you want to add the PS Desktop buttons.
	4 Under Recent databases, locate “PS Sample Mail Database R5.”
	5 To open the Psmail.nsf memo form, click “Forms” and then double-click “Memo.”
	6 Confirm the Action Pane window is visible in the Domino Designer window. If not, click View/Act...
	7 In the Psmail.nsf memo form, click the “Play multimedia” action once and then click the Edit>Co...
	8 Under Recent databases, locate the Notes NAB database for which you want to add the PS Desktop ...
	9 To open the NAB database memo form, click “Forms” and then double-click “Memo.”
	10 If the NAB database is a template, skip to step 14.
	11 Click the File>Database>Properties menus and click the Design tab.
	12 To save the additions of these buttons to this database only, clear the “Inherit design from t...
	13 Save and close the Properties window.
	14 From the Domino Designer, confirm the Action Pane window is visible in the NAB database.
	15 Paste the “Play multimedia” action from the Psmail.nsf file to the NAB database.
	16 In the Action Pane window, click the first action and then click the Edit>Paste menus to copy ...
	17 In the Action Pane window of the Psmail.nsf file, select the “Play by phone” action and then c...
	18 In the Action Pane window of the NAB database, click the first action and then click the Edit>...
	19 Save and close the NAB database memo form.
	20 Repeat this procedure for all users that you want to use “Play by phone” and “Play multimedia.”

	To add the Play By Phone and Play Multimedia agents to the NAB database
	1 From Domino Designer, click the File>Database>Open menus and type the directory path and name t...
	2 Do the same to open the NAB database for which you want to add the macros.
	3 Under Recent databases, locate “PS Sample Mail Database R5.”
	4 To open the Psmail.nsf agents, click “Agents” and then click “PS Multimedia Playback.”
	5 Press and hold CRTL and click “PS telephone playback.”
	6 Click the Edit>Copy menus to copy both agents.
	7 Under Recent databases, locate the Notes NAB database for which you want to add the PS Desktop ...
	8 To open the NAB database agents, click “Agents” and then click anywhere in the Agents Pane wind...
	9 Click the Edit>Paste menus to paste the agents.
	10 Confirm the agents are listed and then close and save the NAB database Agents Pane window.


	Troubleshooting read and unread messages
	Notes mailbox database
	User's Desktop.dsk file
	Notes client as an unread journal log in the Cache.dsk file
	Canonical name problem
	To find the “Canonical Name” field value
	1 Open the users mail file.
	2 Find a document created by that user, highlight and right-click the document.
	3 Select the Document Properties menu.
	4 Click the Fields tab.
	5 In the “From” field list, locate the correct Canonical Name as shown on the bottom right of the...
	6 Highlight, copy, and paste this Canonical Name into the Unified Messaging Trial Software NAB “C...


	Mail file open conflict
	Access Control List problem
	View problems
	Replica database problems
	Notes servers earlier than version 4.5
	Notes limitations
	Minimizing problems
	Confirm that users always access the same mail file replica as Unified Messaging Trial Software. ...
	If one of the replicas is a local replica (on a client), use the "Replicator_sync_unread=-1" sett...
	Access all replicas frequently. If users wait long periods of time between accessing a given repl...
	Avoid using the "Mark all read" or "Mark all unread" settings when using very large mail files (o...
	When using multiple replicas, use the Notes R5 Workspace page to unstack replica icons. Select tw...


	Appendix
	Voice boards
	Proline 2V voice�board
	Switch block SW1
	Hardware settings
	To set switch block SW1 and jumpers JP5, JP6, and�JP7
	1 Set SW1 switches on each board as shown below.
	2 Set jumpers JP5, JP6, and JP7 as shown below.

	To set jumper JP1 (IRQ setting)


	Dialogic D/41H� ISA voice�board
	Switch block SW1
	Hardware settings
	To set switch block SW1 and jumpers JP5, JP6, and�JP7
	1 Set SW1 switches on each board as shown below.
	2 Set jumpers JP5, JP6, and JP7 as shown below.

	To set jumper JP1 (IRQ setting)


	Dialogic D/41E�PCI voice board
	Jumpers JP2– JP5
	Hardware settings
	To set the SW1 switch
	To set switch block SW2
	To set jumpers JP2 to JP7


	Dialogic D/41ESC voice�board
	Pin 1: Unused
	SC bus connector
	Hardware settings
	To set the SW1 switch
	To set switch block SW2


	Dialogic D/120JCT-LS voice�board
	Dialogic D/120JCT-LS voice�board
	Hardware settings
	To set the SW100 switch
	To set the SW1 switch
	On hook



	Dialogic D/160SC-LS voice�board
	SC bus connector
	Dialogic D/160SC-LS voice�board
	Hardware settings
	To set the SW100 switch
	To set the SW4 switch
	Off hook



	Dialogic D/240PCI-T1 voice board
	Switch SW100
	Hardware settings
	To set the SW100 switch
	To set jumpers JP2 to JP7

	LED status indicators
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